Reduced satellite data volumes

Incident Report for Spire Maritime a Kpler Company

Resolved

The satellite feed is back to normal levels.
Posted Mar 02, 2026 - 19:47 UTC

Investigating

We are currently investigating this issue.
Posted Mar 02, 2026 - 09:04 UTC
This incident affected: Maritime 2.0, Maritime TCP 2.0, and Sense Cloud - Messages API.