Partial outage in TCP Server and Uniproxy

Incident Report for Spire Global

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 06:17 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 11, 2025 - 05:55 UTC

Monitoring

The issue causing increased latency and broken connections on TCP stream and Uniproxy has been resolved. A fix was successfully applied and services are now operational. We will continue to monitor to ensure stability.
Posted Jul 11, 2025 - 05:15 UTC

Identified

We are currently investigating reports of increased latency and a spike in broken connections affecting our TCP stream and Uniproxy services. Our engineering team is actively working to identify and resolve the root cause. Further updates will be provided as more information becomes available.
Posted Jul 11, 2025 - 04:45 UTC
This incident affected: Maritime TCP 2.0 and Uniproxy Feed.